Advice Please - Dash Warning Lights

About the Granvia or about whatever....
psft001
Posts: 4
Joined: 03 Jan 2010, 12:19

Advice Please - Dash Warning Lights

Postby psft001 » 23 Jul 2017, 10:10

Had my Granvia (95 3.0 turbo diesel) near on ten years with no trouble at all just routine servicing plus tyres and last year new glow plugs.

Friday night went to collect my daughter from her end of term dance - car running fine, no strange noises or anything and when I restarted the car after picking her up got three warning lights on dash - Oil, Battery and fuel filter! Will have to go to garage as I'm not a mechanic and back issues make it difficult for me to do any work on the vehicle anyway.

Just wanted to sound out the group if anyone has had similar or knows what the likely cause is - just so I have some idea of what the likely cost is going to be!

Thanks in anticipation

Paul

Richard
Posts: 446
Joined: 28 Oct 2008, 16:48
Location: S.E. London

Re: Advice Please - Dash Warning Lights

Postby Richard » 23 Jul 2017, 16:54

My contribution to the speculation:

Multiple warning lights on the dashboard would suggest either:

- low voltage from the battery or alternator. Check the voltage at the battery terminals with the engine running. See postings elsewhere on what the readings should be (~13V). The problem could be poor charging from the alternator requiring repair or replacement.

- one of the multi-pole connectors to the dashboard has come loose. Remove the dashboard (see posts elsewhere for the instructions) and reattach all the connectors.

What are the precise symptoms? What happens to the warning lights when the ignition is first switched on? Are the warning lights illuminated continuously? Do they flicker or go out when the engine is revved? (If the lights are illuminated only at low revs, I'd suspect a failing alternator.)

Richard

psft001
Posts: 4
Joined: 03 Jan 2010, 12:19

Re: Advice Please - Dash Warning Lights

Postby psft001 » 23 Jul 2017, 17:24

thanks for that Richard. When ignition on all lights come on as per usual - once engine running the oil/battery/fuel filter lights remain on - haven't tried to see what they do when engine revved - certainly didn't seem to flicker at idle - will try tomorrow.

From other posts I'd seen I suspected failing alternator - hopefully not too expensive to sort!


Return to “general chit chat”

Who is online

Users browsing this forum: No registered users and 2 guests