odd warning lights on - not charging?

Mechanical questions about the Toyota Granvia
MrDillon
Posts: 204
Joined: 30 Nov 2008, 20:45

Re: odd warning lights on - not charging?

Postby MrDillon » 10 Dec 2012, 21:00

Hi Richard

Any auto electrician (mine was in Bury St Edmunds in Suffolk - if any use to you) covering japanese cars should be able to help, and I think replacement rotors and brushes are readily available for them. I would suggest putting it into someone good and have them give the whole unit the once over. Mine came to £70 all in for a new rotor and complete health check.

Alternator remval is straightforward if a little innaccessible (as many things on this vehicle are!) in that the lower mounting bolt is tucked away a bit. Can't remember if it screws directly into the mounting bracket or needs to be held at the back with a spanner whilst you undo from the front - I have a feeling it does. Dont forget to disconnect the earth strap from the battery before you touch the terminal on the alternator!

And I think you have to juggle it about a bit to feed it through the space - might be an idea to remove the air filter housing to give a bit more room

Good Luck

MrD

Richard
Posts: 463
Joined: 28 Oct 2008, 16:48
Location: S.E. London

Re: odd warning lights on - not charging?

Postby Richard » 16 Dec 2012, 18:11

Thanks for the info on the alternator brushes, but first I have to get the dratted alternator out!

After much cursing over the inaccessibility of the components and having to remove so much paraphernalia to even get at the bolts, I've now removed the pivot bolt and the adjusting bolt+clamp bolt*, but although I can move the alternator by a few millimeters laterally within the alternator bracket, I just can't extract the alternator between the alternator positioning bracket (the curved slotted bracket which seems to disappear under the front of the engine) and the air conditioning compressor above it. Is it necessary to move either the positioning bracket or the compressor?

Richard

* Neither the pivot bolt nor the clamp bolt have nuts - both bolts attach directly into threaded holes in the alternator body. One small mercy at least....

MrDillon
Posts: 204
Joined: 30 Nov 2008, 20:45

Re: odd warning lights on - not charging?

Postby MrDillon » 16 Dec 2012, 20:40

Hi Richard

I think I may have removed the aircon compressor - I freed off the belt first and once the compressor was free just move it away from the block (leave the pipes connected) - I may have rermoved its bracket from the engine as well to give some more room

Obvious thing but you have unbolted the cable from the alternator terminal as well?!!

Good Luck
MrD

Richard
Posts: 463
Joined: 28 Oct 2008, 16:48
Location: S.E. London

Re: odd warning lights on - not charging?

Postby Richard » 29 Dec 2012, 19:44

Thanks for the advice and info!

We've just done a short test run and our Granvia seems to be fully functional again.

In the end, I bought a replacement alternator here (www.startermotor-alternator-store.co.uk/toyota-4-runner-30-td-alternator---1993-95-a2054-6045-p.asp) for £135 incl delivery. When I got the old alternator out, the brushes seemed in good condition so the problem must have been in the electronics or internal wiring - since I couldn't shift the screw securing the brushes anyway and having no experience or ready source of components, getting a whole reconditioned unit seemed the simplest solution. The alternator supplied appears to be a Chinese-manufactured copy of the NipponDenso original, exact down to the ventilation slots, and even comes with the test results including a graph of the current output against engine speed, but just a few comments: a) the fastenings on the Chinese copy are even worse than NipponDenso's; b) the brush holder and dust seal don't look new - maybe just new brushes soldered into a recycled NipponDenso holder; c) the double-groove pully is *not* the same as the original Granvia - although it's the same diameter, the two grooves are slightly further apart (by a millimeter or so) so the belts are going to have to be slightly misaligned.

Getting the old alternator out was simply a matter of applying a little more force - the long curved alternator-positioning bracket just flexed outwards enough to let the alternator out, so there's no need to move the air-conditioning pump or the bracket. And surprisingly, the new alternator went back in with very little trouble, just needing some cursing and yanking to get it to line-up to allow the pivot bolt to thread through.

So none of the dashboard lights are indicating any problem and there's 14.4volts at the battery terminals with the engine idling. I wonder if anything else is going to fail or will we have another few years of trouble-free motoring.........

Richard
Posts: 463
Joined: 28 Oct 2008, 16:48
Location: S.E. London

Re: odd warning lights on - not charging?

Postby Richard » 10 Jan 2013, 20:57

Maybe I'm maligning the Chinese "copy" unfairly!

When I went to tighten-up the bolts yesterday after a long run, I noticed that the pulley-wheels on the crankshaft and the fan have roughly the same spacing as the replacement Chinese alternator. It looks like the NipponDenso alternator fitted to my Granvia was the one with the wrong spacing.

Zouiesv
Posts: 1
Joined: 16 Jan 2018, 10:06

Re: odd warning lights on - not charging?

Postby Zouiesv » 16 Jan 2018, 10:18

Upping old topic, but the alternator relay is mentioned in this one... i have hard time to locate it, so where it is?

I have opened the passengers footwell covers, i can hear the "click", but do not see the relay. One denso relay is clearly visible, but it is not that one in the middle.


Return to “how do i”

Who is online

Users browsing this forum: No registered users and 1 guest